Instalação ABCD

ABC do ABCD

ABCD versão 1.0 veio originalmente em três versões principais:

  1. pacote de instalação não assistida para Windows: este é um arquivo ZIP contendo todos os arquivos necessários, que simplesmente precisa ser descompactado na raiz de (um de seus) discos rígidos, por exemplo, C: . Uma vez que abrange o Apache e PHP, depois de simplesmente descompactá-lo deve funcionar normalmente! Aqui o Apache vem com seu próprio arquivo de configuração (httpd.conf) onde a porta 9090 é ativada para permitir a execução próxima a possíveis outras instalações do Apache em execução.
    Apenas para alguns usos específicos, por ex. o uso de Z39.50 que precisa de módulos PHP adicionais (YAZ), será
    necessário fazer alguma edição (por exemplo, php.ini).
    As instalações ABCD que usarão o módulo de Empréstimos Avançados (EmpWeb) precisam descompactar adicionalmente o pacote EmpWeb …. zip mais recente, onde uma subpasta principal extra em \ ABCD será criada e alguns arquivos adicionais serão adicionados ao diretório ABCD Central.
  2. instalação assistida para Windows: este é um executável de instalação automática, que verificará primeiro se o Apache e o PHP já estão instalados no sistema. Em caso afirmativo, essas instalações serão ignoradas, caso contrário, serão adicionadas ao a instalação básica do ABCD. Isso requer principalmente seguir as caixas de diálogo e as instruções do próprio instalador.
    No final, um diretório-pasta semelhante ao do pacote em 1. será o resultado.
  3. pacote de instalação não assistida para Linux: este é um arquivo .tar.gz para sistemas Linux que deve ser descompactado no sistema de arquivos Linux, dependendo de sua organização (definição de onde tais aplicativos podem estar colocar). Se os direitos de acesso corretos forem concedidos (com os comandos Linux apropriados, como chown e chmod) O ABCD pode ser instalado, como no Windows, na raiz do sistema de arquivos ‘/’. Em sistemas Linux, a suposição é que Apache e PHP são instalados separadamente (por exemplo, com a ferramenta dedicada como apt-get ou Synaptic), então o pacote contém apenas os arquivos ABCD apropriados no diretório ‘www’. A distribuição da nova versão 2.0 é simplificada: o ABCD não vem mais com sua própria configuração de Apache com PHP para Windows, já que hoje em dia existem pacotes de instalação muito bons para esses ambientes (WAMP, XAMP), mas também esses pacotes estão em uma posição melhor para manter as diferentes versões do Apache (ASF, Bauhaus ??) em thread-safe ou não compilado com uma das muitas versões do MS Visual C (9, 10 … 14) simplificado com o correto versões de PHP, novamente versões de 32 ou 64 bits, etc.
    Portanto, a instalação do Windows agora é muito semelhante à do Linux: o Apache e o PHP devem
    foram pré-instalados e configurados. ABCD só precisa de um arquivo de configuração de ‘host virtual’ para ser adicionado ao Servidor Apache para rodar a partir dessa versão pré-instalada. Em, por exemplo WAMP o arquivo – vindo com a instalação
  4. httpd-hosts-abcd.conf simplesmente precisa ser adicionado ao diretório ‘alias’ e o Apache reiniciado.


Problemas de instalação


Esta seção trata dos problemas de instalação do ABCD. Como o ABCD tem vários componentes totalmente diferentes,
a instalação, por definição, abrange algumas armadilhas potenciais.

Três razões principais podem ser dadas para a instalação ser complexa:

  1. ABCD é uma combinação de várias tecnologias de software: bancos de dados ISIS, scripts ISIS e formatos ISIS, um
    servidor web, script de PHP, mais (no caso do módulo de Empréstimos avançado) algumas partes JAVA e MySQL;
  2. ser baseado na web, o que significa que um servidor web deve ser instalado e medidas especiais devem ser tomadas sobre direitos de acesso e segurança: em princípio, todo o mundo – com acesso à WWW – pode interferir.
  3. O ABCD será instalado em situações bastante diferentes, variando de um simples autônomo (até mesmo sem rede)
    PC até servidores em grandes redes com um servidor web e muitas vezes também serviços de script PHP pré-instalados.
    Anteriormente, os pacotes de instalação vinham em dois tipos:
  4. um pacote completo, contendo todos os arquivos apropriados para ABCD, mais o servidor web Apache e o mecanismo de script PHP.
    Nesta situação, um arquivo (.zip) precisa ser descompactado em uma pasta raiz do sistema de arquivos (que pode ser qualquer sistema operacional no qual Apache / PHP e ISIS podem ser executados). Depois de descompactar, haverá uma pasta dedicada para Apache, outro para PHP, uma pasta cgi (para conter os executáveis ​​acessíveis pela web) e uma pasta ‘documentos’ (no Apache chamado ‘htdocs’) que atua como a página inicial do aplicativo ABCD.
    • O Apache vem com um arquivo de configuração pré-definido (httpd.conf na subpasta conf da pasta Apache)
    que define os seguintes parâmetros específicos:
Perâmetros do ApacheDescrição
ServerRoot”/ABCD/apache”Diretório a partir do qual o Apache é executado
Listen 9090A porta usada pelo ABCD, sendo a porta http por default 80, mas para evitar interferência com outras aplicações http existentes, se assim o desejar, uma porta diferente pode ser usada, por exemplo, 9090. No caso de utilizar um número de porta diferente, algumas adaptações terão que ser feitas no script ABCD_start.bat e, em algumas URLs do OPAC.
PHPIniDir “/ABCD/php”A pasta a partir da qual PHP é executado
DocumentRoot “/ABCD/www/htdocs”A pasta-raiz de todos os arquivos que fazem parte da própria aplicação, ou seja a ‘homepage”
ScriptAlias /cgi-bin/ “/ABCD/www/cgi-bin/”A pasta na qual o Apache irá permitir a execução dos executáveis a partir de instruções nas páginas web

Nota
Certifique-se de que o módulo ‘cgi’ do PHP está instalado no Apache, o que não é mais o caso (como antes) em novas instalações do Apache. O comando para instalar este módulo no Linux baseado em Debian é:

sudo a2enmod cgi

O PHP vem com uma configuração predefinida em php.ini.

Configurações de PHP e php.ini

Já que ABCD usa PHP com alguns módulos PHP adicionais (YAZ, XSLTProcessor …) Pears
deve ser instalado dentro da instalação do PHP e alguns módulos extras precisam ser copiados para a pasta de ‘extensões’ do PHP: php_yaz.dll, yaz.dll, yaz3.dll (estes dois servem a função Z39.50 de catalogação ABCD),
iconv.dll, libxm2l.dll, libxslt.dll (para o processador XSLT). A pasta PHP-extensions precisa estar presente
na variável de ambiente do caminho do sistema (no Windows, por exemplo: vá para ‘Meu computador (clique com o botão direito) | Propriedades |
Avançado | Variáveis ​​de ambiente | Variáveis ​​de sistema e editar a variável de caminho adicionando, se não estiver presente:
‘; C: \ ABCD \ php \ ext’). Certifique-se também de que seu php.ini (em \ ABCD \ php) tenha as extensões mencionadas aqui comentadas (ou seja, remova o caractere ‘;’ para ativar a extensão).
extension = iconv.dll
extension = iconv.dll
extension = libxml2.dll
extension = libxslt.dll
extension = yaz3.dll
extension = php_yaz.dll
Tenha cuidado com a possível existência de outros arquivos php.ini, por exemplo, em \ Windows ou \ PHP, pois podem atrapalhar o seu ABCD-PHP. Uma opção de teste de PHP está disponível com ABCD no URL: http: // localthos: 9090 / info.php. Nós estamos especificamente interessado na seguinte seção abaixo, onde XSL e YAZ devem ser mencionados como em execução se não, verifique sua variável de ambiente de caminho e todos os caminhos novamente, bem como a seção ‘extensões’ de seu php.ini!

O arquivo php.ini contém mais algumas configurações que precisam ser verificadas para que o ABCD funcione corretamente:
• register_globals = On (padrão = Off)
• extension_dir = “/ ABCD / php / ext” (ou ajuste para o caminho real para a instalação do ABCD)
• default_charset = “iso-8859-1” (padrão = não ativo) ou “utf8” se Unicode for usado
• extension_dir = “/ ABCD / php / ext” => define o diretório de extensões
• extension = yaz3.dll e extension = php_yaz.dll estão listados em => são adicionados na seção ‘Extensões dinâmicas’ para permitir que o módulo YAZ para Z39,50 funcione
Nota
A partir do ABCD 2.0 não é mais necessário manter a configuração para ‘short_open_tag’ para ‘On’ (o que é contra-indicado de qualquer maneira). Tudo aberto
tags ” <? ‘ foram alterados para ‘<? php’.

um pacote apenas ABCD, exigindo Apache (ou outro servidor web) e PHP já instalado.
Neste caso, o pressuposto é que pelo menos alguma experiência está disponível para entender o servidor web existente instalação e configuração do PHP. Usando ‘aliases’ para a instalação ABCD e pasta cgi, que podem ser colocados
em um arquivo de configuração de host virtual, o ABCD pode ser instalado em qualquer lugar dentro ou fora da pasta pessoal existente para o servidor web. Portanto, apenas a pasta cgi e a pasta htdocs estão incluídas neste pacote. Os gerentes de sistema devem consultar os manuais do Apache e do PHP caso não tenham certeza sobre como proceder com este tipo de instalação.
Como alternativa, também é possível usar instalações predefinidas como EasyPHP ou WAMP (para Windows) / XAMP
(para UNIX / Linux). Novamente, neste caso, Apache e PHP (e MySQL) serão instalados automaticamente e o
As pastas ABCD cgi-bin e htdocs devem ser movidas para as estruturas de pastas existentes (do Apache) e php.ini
tem que ser editado.
A partir do ABCD 2.0 somente o segundo tipo de distribuição estará disponível, restando a instalação do Apache e
PHP para outros pacotes mais especializados, como WAMP ou XAMP. Apenas um arquivo de configuração específico de ‘host virtual’ para ABCD precisa ser adicionado à configuração do Apache (por exemplo, no WAMP: colocando-o no diretório ‘alias’) e algumas configurações de PHP precisam ser verificadas no php.ini para ativar extensões adicionais. para gd2, libxml, xsl, e se as funções relacionadas são usadas: ldap, yaz, mysqli (para Empweb) e mbstring (para Unicode).
Uma ferramenta de instalação dedicada será criada como parte do software ABCD, mas em essência ainda fará o mesmo que descrito acima, somente após coletar alguns parâmetros de instalação (como qual disco usar, qual porta etc.).

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *